Code that is more self-explanatory, and easier to read without putting silly "//end if" style comments in.
Like when you've got stuff like this:
for (x=0;x<=10;x++)
{
if (x == something)
{
for (y=0;y<=whatever;y++)
{
doStuff()
if (x == y)
{
doMoreStuff()
}
}
}
else
{
while (x < y)
{
doEvenMoreStuff()
}
}
}
It'd be easier to read if it was more like this:
x:loop(0..10)
if (x = something)
y:loop(0..whatever)
doStuff()
if (x = y)
doMoreStuff()
/if
/y:loop
else
while (x < y)
doEvenMoreStuff()
/while
/if
/x:loop
And similar things to that.
Syntax that is intuitive and sensible, and thought out properly.